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Week Date Teaching  Attended  

2 18/11/10 Lab 8: Network Forensics - Packet 

Capture & Analysis  

 

 

 

Aim:  The aim of this lab is to provide a foundation in network packet capture and analysis, 

as an incident response activity in Network Forensics.   

 

Time to complete:  

4/5 hours (Two supervised hours in B.56, and two/three additional hours, unsupervised).  

 

Activities : 

¶ Complete Lab 8: Packet Capture & Analysis/Toolkit.  

.pdf from WebCT or  http://www.dcs.napier.ac.uk/~cs342/CSN10102/Lab8.pdf  

 

¶ Complete the End Of Unit Test for this chapter at:  

http://buchananweb.co.uk/adv08 .html  

 

Learning activities:  

At the end of these activities, you should understand:  

¶ How to capture network traffic for forensic purposes . 

¶ How to analyse network captures in th e context of an incident response. 

 

 

Reflective statements (end -of -exercise): 

How does capturing network traffic help in the event of a security incident ? 

 

What are the key tools and file formats used in network forensic analysis ? 

 

 

Source code used: 

http://buchananweb.co.uk/toolkitnew.rar  

 

http://buchananweb.co.uk/toolkitnew.rar
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Lab 8: Network Forensics - Packet   
Capture and Analysis 

8.1 Details 

Aim:   To provide a foundation in network packet capture and analysis, and in the context 

of an incident response activity  in Network Forensics .   

 

   You may be faced with network traffic analysis, from traffic captured yourself or 

monitoring data given to you by on -site IT staff. A popular tool for capture and 

analysis of network traffic is Wireshark (formerly known as Ethereal).   

8.2 Wireshark  

 

8   On-line demo:  

http://buchananweb.co.uk/adv_security_and_network_forensics/ wireshark/wireshark .htm 

 

The lab has two elements: the host machine (DESKTOP ) and the Windows virtual image 

(WINDOWS2003 ) as shown in Figure 1. 
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Figure 1 - Lab1 Architechture  

 

8  An overview of Windows XP commands , to assist with the lab,  can be found at:  

http://www.microsoft.com/resources/documentation/windows/xp/all/proddocs/en -us/ntcmds.mspx 
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8  The Wireshark User Guide, to assist with the lab, can be found at:  

  http://www.wireshark.org/docs/wsug_html_chunked/  

 

8.2.1 Run the Windows Server 2003 virtual image (run the .vmx  file, and power the virtual 

machine) Log in to the server using: Username: Administrator , Password: napier ).  

 

 Within the virtual image, open a command line window and determine the virtual 

servers IP address using the Windows command  ipconfig . Similarly, from 

DESKTOP open a command line window and determine the IP Address of the host PC 

using the Windows ip config  command. 

    

F Complete the IP Addressing diagram in Figure 2, by filling  in the IP addresses of the 

host PC, the virtual server and the network address which will be used to connect to 

the virtual image.  
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Figure 2 - Lab1 IP Addressing  

 

 

L1.2 To check connectivity, from DESKTOP, ping  WINDOWS2003, and vice-versa. 

 

F Were the pings successful?       YES/NO  

 

 

 

8.2.3 From WINDOW2003, run  the Wireshark  application . When Wireshark is first run, a 

default, or blank window is shown. To list the available network interfaces, select the 

Capture->Interfaces  menu option  as shown in Figure 3 . 

 

 

http://www.wireshark.org/docs/wsug_html_chunked/
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Figure 3 - Wireshark Interfaces  

 Wireshark should display a popup window such as the one shown in  Figure 4. To 

capture  network traffic click the Start button for the network interface you want to 

capture traffic on.  Note: The Packets column, to the left of the start button shows the 

total number of incoming packets for each interface. 

 

 

Figure 4 - Wireshark Interfaces Window  

8.2.4 Generate some network traffic with a Web Browser  from within WINDOWS2003 . 

Your Wireshark window should show the traffic, and now look something  like Figure 

5. Note : The web browser produced traffic to and from port 80, which Wireshark 

interprets as HTTP  in the Protocol  column. 
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Figure 5 - Wireshark Capturing Traffic  
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To stop the capture, select the Capture->Stop menu option, Ctrl+E, or the Stop toolbar 

button. What you have created is a Packet Capture or ȿpcapɀ, which you can now view 

and analyse using the Wireshark interface.  
 

The capture is split into 3 parts: 

1. Packet List Panel ɬ this is a list of packets in the current capture. It colours the 

packets based on the protocol type. When a packet is selected, the details are 

shown in the two panels below.  

2. Packet Details Panel ɬ this shows the details of the selected packet. It shows the 

different protocols making up the layers of data for this packet. Layers include 

Frame, Ethernet, IP, TCP/UDP/ICMP, and application protocols such as HTTP. 

3. Packet Bytes Panel ɬ shows the packet bytes in Hex and ASCII encodings.  

 

  

 

Search through your capture, and find an HTTP  packet containing a GET command. Click 

on the packet in the Packet List Panel. Then expand the HTTP layer in the Packet Details 

Panel, from the packet.  

 

F From the Packet Details Panel , within the GET command, what is the value of the Host  

parameter? 

 

 

F Can you see the Hex and ASCII showing the raw bytes in the Packet Bytes Panel? 

 

 

 

 

8.2.5  A Packet Capture or ȿpcapɀ can be saved to disc, for later analysis. To save a capture, 

select File->Save AsȮɯÈÕËɯÜÚÌɯÛÏÌɯËÐÈÓÖÎɯÉÖßȭɯ3ÏÐÚɯÊÙÌÈÛÌÚɯÈɯȿȭpcapɀ fileȭɯ3ÏÐÚɯÉÈÚÐÊɯȿ2ÈÝÌɯ

 ÚɀɯÚÈÝÌÚɯÈÓÓɯÛÏÌɯÊÈ×ÛÜÙÌËɯ×ÈÊÒÌÛÚɯÛÖɯÛÏÌɯÍÐÓÌȭ 

 

 

Note: A .pcap file is a common format which many tools can r ead and write. For 

example a tcpdump  or win dump output file is in this format , and can be read into 

Wireshark  for analysis. Other useful network forensic tools, which can operate on 

.pcap files, include NetworkMiner ɬ another capture and analysis tool, tcp stat  - for 

generating capture statistics, and Snort ɬ for generating intrusion alerts from capture 

files.  
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Wireshark Analysis - Display Filters  
8.2.6  Right click on the Source Port field in the Packet Details Panel . Select Apply as 

Filter ->Selected 

 

 
 

Wireshark automatically generates a Display Filter , and applies it to the capture. The 

filter is shown in the Filter Bar , below the button toolbar. Only  packets captured with 

a Source Port of the value selected should be displayed. The window should be similar 

to that shown in Figure 6. This same process can be performed on most fields within 

Wireshark, and can be used to include or exclude traffic.  

 

Display 

Filter Bar

 

Figure 6 - Filter B ar 
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Wireshark Analysis - TCP Conversations   
8.2.7 Start a capture, and generate some Web traffic from the WINDOWS2003 virtual 

server, by going to www.schneier.com , and then stop the capture. Scroll back to the 

top of the capture trace. Find the first SYN packet, sent to the Web Server. This 

signifies the start of a TCP 3-way handshake.   

 

If your having trouble finding the first SYN packet, select the Edit ->Find Packet 

menu option. Select the Display Filter radio button and enter a filter of tcp.flags. (at 

thi s point you should get a list of the flags to choose from). Choose the correct flag, 

tcp.flags.syn  and add == 1. Hit the Find  button, and the first SYN packet in the trace 

should be highlighted.  

Note:   The Find Packet function can also be used to search for a Hex signature ɬ such 

as an attack signature, or to search for a string ɬ such as a protocol command - in a 

Packet Capture (pcap).  

 

 
 

 

F Can you identify the rest of the TCP 3-way handshake easily? (if not read on) 

 

               YES/NO 

 

 

8.2.8 A quick way to create a Wireshark Display Filter  to isolate a TCP stream is to right 

click on a packet in the Packet List Panel and select Follow TCP Stream.  This creates 

an automatic Display Filter which displays packets from that TCP session only. It 

also pops up a session display window, containing an ASCII representation of the 

reassembled TCP session (client packets in red, server packets in blue). The window 

should look something like Figure 7Error! Reference source not found. .  

http://www.schneier.com/
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Figure 7 - Follow TCP Stream  

This is very useful for viewing human readable protocol payloads  of conversations, 

such as with the  HTTP, SMTP, and FTP  protocols. For example you can reconstruct 

web pages seen by a user, or view unencrypted email/IM conversations.  

 

If you close the popup window. Wireshark now only shows the packets from the 

selected TCP Stream. You should be able to identify the 3-way handshake as the first 

three  packets. 

 

 
 

F From your Wireshark Capture, fill in the diagram below with the IP Addresses and 

Port Numbers for the Client and the Server 

 

F For each packet in the TCP 3-way handshake, fill in the Sequence and 

Acknowledgement  numbers, on the diagram below. 

 

Flags: SYN, Seq: ______

Client

Flags: SYN, ACK Seq: ______, Ack: ______

Flags: ACK,  Seq: ______, Ack: ______

Server

IP Address:

_____________

IP Address:

_____________

Port Number:

_____________

Port Number:

_____________
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8.2.9 Often captures should be saved to disc, for later analysis. To save a capture, select 

File->Save As, and use the dialog box as normal. This creates a pcap file, which 

many tools read and write. For example a tcpdump output file is in this format and 

can be read into Wireshark for analysis. This saves all the captured packets to the file. 

 

F Did you successfully save your capture to disc? 

 

F Copy the Display Filter  into the clipboard, and close and start Wireshark again, then 

reload the file. Was the whole capture saved or just the displayed packets? 

 

 

Paste the display filter back into the Filter Bar, and Apply it.  

To save only the displayed packets, select File->Save As again, but this time select the 

Displayed radio button rather than the default Captured. This creates a pcap file, with 

only the packets filtered by the current display filter. This can be useful when 

analysing large captures, as interesting packets can be saved  

 

F Close and start Wireshark again, then reload the file. Was the whole capture saved or 

just the displayed packets? 

 

 

 

8.2.10 Start another capture, and generate some Web traffic from the DESKTOP host, by 

going to www.schneier.com  again, and then stop the capture. Scroll back to the top of 

the capture trace.  

Note:  Some useful display filters  can be found at: 

http://wiki.wireshark.org/DisplayFilters  

 

F Create a display filter to show only web traffic involving the the DESKTOP host. What 

is the display filter?  

 

 

 

 

  

http://www.schneier.com/
http://wiki.wireshark.org/DisplayFilters
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Wireshark Analysis - Statistics 
 

8.2.10  Wireshark provides  a Statistics menu, which provides tools to help narrow the focus 

of a network forensic investigation , including overall statistics, conversations, and 

information on systems involved in the conversations. 

 

Start the capture, and generate some Web traffic by going to www.schneier.com , 

then stop the capture, and select the Statistics->Protocol Hierarchy menu option. A 

window similar to that shown in Figure 8 should be shown, displaying statictics 

about the pcap. Note that all the packets are L2 Ethernet (Local Area Network) 

packets, but at the network layer most of the packets are TCP, but some are UDP 

 

 

 

Figure 8 - Protocol Statistics  

 

F What percentage of packets in your capture are TCP, and give an example of the 

higher level protocol which uses TCP? 

 

 

F What percentage of packets in your capture are UDP, and give an example of the 

higher level protocol which uses UDP ? (use Figure 9) 

 

 

 

http://www.schneier.com/
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Figure 9 - Network Model with Protocols  

 

8.2.11 Select the Statistics->Flow Graph menu optio n. Choose General Flow   and Network 

Source options, and click the OK button. A window similar to that shown in Figure 

10 should be displayed, visualising  the flow of traffic. Other useful options in the 

Statistics menu include the Statistics->IP Addresses option which categorises all IP 

Addresses traffic, in the current pcap capture. 

 

 

Figure 10 - Traffic Flow Graph  
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8.3 Network Forensic Analysis of Capture Files 

 

8.3.1 Download , and unpack, the following capture file  (.pcap): 

8  http://buchananweb.co.uk/labforensics.rar  

 

Use Wireshark  to analyse the capture file for the following traffic . 

 

8.3.2 For the TELNET  traffic, determine the following:  

 

MAC Addresses of Hosts involved:  

 

 

IP Addresses of Hosts involved:  

 

 

Incorrect login details:  

 

 

Correct login details:  

 

 

Commands used once logged in:  

 

 

TCP ports used: 

 

 

 

8.3.3 For the HTTP  traffic, d etermine the following:  

 

MAC Addresses of hosts involved:  

 

 

IP Addresses of hosts involved:  

 

 

Pages requested: 

 

 

TCP Ports used: 

 

 

 

8.3.4 For the FTP traffic, d etermine the following:  

 

MAC Addresses of Hosts involved:  

 

 

IP Addresses of Hosts involved:  

 

 

Incorrect login details:  

 

 

Correct login details:  

 

 

Commands used once logged in:  
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File uploaded to server:  

 

 

File downloaded from the server:  

 

 

TCP Ports used: 

 

 

 

8.3.5 For the PING (ICMP)  traffic , determine the following:  

 

MAC Addresses of hosts involved:  

 

 

IP Addresses of hosts involved:  

 

 

Success rate and number of times 

scanned: 

 

 

 

8.3.6 For the NMAP  traffic, d etermine the following:  

 

MAC Addresses of hosts involved:  

 

 

IP Addresses of hosts involved:  

 

 

Successful ports connected to (list ten 

examples): 

 

 

 

 

 

Unsuccessful ports not connected to 

(list ten examples):  

 

 

 

 

 

 

8.3.7 For the SSH traffic, d etermine the following:  

 

MAC Addresses of Hosts involved:  

 

 

IP Addresses of Hosts involved:  

 

 

Incorrect login details:  

 

 

Correct login details:  

 

 

TCP ports used: 
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8.4 Toolkit 8 ï IP Location  

 

The objective of this series of labs is to build an integrated toolkit. Download and unpack : 

8  http://buchananweb.co.uk/toolkitnew.rar  

 

The objective of this part of the toolkit development is to create an application which shows 

the location of an IP address, such as shown in Figure 11. 

 

 

Figure 11 - IP Address Locator  

 

8.4.1 From the unpacked toolkitnew  directory , open the Visual Studio solution 

clientServerDraft.sln , and select the client .cs Windows form.  

 

8.4.2 Select the Network  tab, and then the Location  tab, as shown in Error! Reference 

source not found. . 

 

8.4.3 Double click on the Go button and add the following code  to the click event handler : 

 

        private  void  button130_Click( object  sender, EventArgs  e)  

        {  

            getMap();  

        }  

 

  

http://buchananweb.co.uk/toolkitnew.rar

